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Data Management

Learn about the Autodesk® data management system and its configurations.

Key Terms

Term Definition

Autodesk® data management server The server used in conjunction with Au-
todesk® Vault, Autodesk® Productstream®,
and Content Center for storing files and
version data.

Autodesk Vault A system for data management and version
control.
A general purpose application for interact-
ing with a vault on the Autodesk data
management server. You can browse the
complete vault structure, add any file to
the vault, and perform most other file-
based operations, depending on your level
of permission.

client Applications that access the Autodesk data
management server. These include stand
alone applications such as Autodesk Prod-
uctstream as well as integrated application
add-ins such as Autodesk Vault for Inventor
or Autodesk Vault for Microsoft® Office.




Term Definition

data management A means to organize and track files and
design modifications through the design
process.

server The central location where all the vault

data is stored and from which it is re-
trieved. The server must always be online
for clients to access the vault. The vault
server is configured using ADMS Console.

vault The logical combination of a vault database
and a vault file store that contains all of the
information managed by Autodesk Vault.
Each installation of Autodesk Vault can
maintain several independent vaults. A
single client can connect to several differ-
ent vaults, but not simultaneously.

About Autodesk Vault

Autodesk Vault is a workgroup data management system for sharing design
data across a project team. The vault is a file management and version control
system for all engineering and related data providing design team members
with a central and secure collaborative environment. Autodesk Vault consists
of two components: the Autodesk data management server and vault clients.
The server stores the master data files of all design information. The clients
provide access to the files stored on the server.

Design teams use Autodesk Vault for version control and to store and share
all types of engineering files and related data. Files can be Autodesk Vault,
AutoCAD®, Autodesk® DWF™ (Design Web Format), FEA, CAM, Microsoft®
Word, Excel®, or any other file used in the design process.
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Vault Client

Database (Windows XP Pro Preferred)
— Network ()
Web
Server
File
Store

Vault Client

\_ J  (Windows XP Pro Preferred)

Single Vault Server (Windows
2003 Server Preferred)

Autodesk Vault

Autodesk Vault is a general purpose application for interacting with a vault
on the Autodesk data management server. You can browse the complete vault
structure, add any file to the vault, and perform most other file-based
operations, depending on your level of permission.

Autodesk Vault Add-ins for Design Applications

Add-in clients provide basic vault functions within the environment of a
parent application. Add-ins maintain application-specific data relationships
when adding files to a vault.

There are add-ins available for Autodesk and non-Autodesk® design
applications.
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NOTE As a general rule, if an integrated client is available for a particular
application, managing files using that client minimizes loss of data, such as the
assembly relationships. We recommend that you use integrated clients whenever
possible.

Microsoft Office Add-in

The Microsoft® Office Add-in performs basic vault functions on documents,
spreadsheets, and other non-CAD data within any of these Microsoft Office
applications: Word, Excel, and PowerPoint®.

Data Management
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All versions of files checked into the vault are retained, along with any file
dependencies, providing a living history of the project. Team members have
access to the files and data stored on the server, and the history of files. They
check out files to prevent more than one member from editing the same file
at the same time. After a file is checked back into the vault, team members
can refresh their local copies.

Data Management



Vault Clients

Learn how to configure vault clients and how to log in to a vault.

AboutVault Clients

Vault clients include the following software applications:

Client Software

Description

Autodesk® Vault

A stand-alone client providing full access
to a vault.

Vault add-in for Autodesk® Inventor™

Manage parts, assemblies, and other Au-
todesk Inventor files that are stored in the
vault from the Autodesk Inventor interface.

Vault add-in for AutoCAD®

Perform basic vault functions within Auto-
CAD, AutoCAD® Mechanical, AutoCAD®
Electrical, and Autodesk® Mechanical
Desktop®.

Vault add-in for Microsoft® Office

Perform basic vault functions on docu-
ments, spreadsheets, and other non-CAD
data within any of the Microsoft Office
applications.




Logging In to Vault

When Autodesk data management server is installed, a vault and a user account
are created. The name of the vault is Vault. The account name is administrator.
No password is assigned to the account and the name is not case sensitive.
The administrator account has full administrator privileges.

NOTE If a user account has already been created for you, log in using your user
name and password.

Log into Autodesk data management server the first time

1 Use one of these methods:

B On the Start menu, click Programs » Autodesk » Autodesk Data
Management » Autodesk Vault (version).

B On the Start menu, click Programs » Autodesk » Autodesk Data
Management » Autodesk® Productstream® (version).

B In an application with an integrated add-in, click File » Autodesk
Data Management Server » Log In.

File | Edit Wiew Insert Format  Tools Table ‘Window Help  Adobe PDF  Acrot

... Fl ot @ L HLE

= Chrl+0

=

L L
IQI

Open From Yaulk, ..

Close
16 12 20 22 24 26

| Zave Chrl+s :
Save As...

id| Save as Web Page...

%1 File Search, ..

| Autodesk Vaul: 4 ||,.‘ Log Ir...
Permission 3 Log Ok
Versions... Check In...
‘Web Page Preview Check Cut
Page Setup... Undo Check Out

_l Prink Preview Refresh Status

= Print... Chrl+P Options. ..
Send To » | B Launch vaul Explorer

2 In the Log In dialog box, verify the following:
User name The name for the vault account.

6 | Chapter 2 Vault Clients



Password The password associated with the vault account.

Server The name of the computer on which the vault
server is installed.

Database The name of a vault database located on the speci-
fied server. The default is “Vault”. Click the browse
button to select from a list of available databases
on the server.

3 A default user ID, vault server, and database are set up for you to get
started using the vault right away. If a user account has already been
created for you, use your own account information. If a user account has
not been created for you, or the default values are not present, contact
your vault administrator.

4 Use either the default values or, if an account has been created for you,
use your own account information. The default values are:

5 User Name: Administrator
Password: empty

server: Name of the computer on which the vault server is installed.
Use localhost if the server is installed on the same machine as the client.

Database: Vault

6 Click OK.

You are logged into the vault.

NOTE You have the option to save the account information to automatically log
into the vault the next time.

Logging In toVault | 7






Autodesk Vault

Manage files using Autodesk® Vault, the general purpose interface to Autodesk® data
management server.

Key Terms

Term Definition

check in Returning a modified file to the vault. The previous version is retained in the
file history.

check out Retrieving a read/write copy of a file stored in the vault for editing.

latest version The most recent version of a file stored in the vault.

local copy The copy of the vault source file placed in the local working directory.

previous version An older version of a file stored in the vault. Previous versions of a file are retained

and are accessible at any time.

Working with Autodesk Vault

Use Autodesk Vault to manage folders and files within a vault.
W Start Vault

B Manage folders



Manage files
Manage file versions

Perform searches

Package files

Starting Autodesk Vault

Start Vault

B On the Microsoft® Windows® Start menu, click Programs » Autodesk
» Autodesk Data Management » Autodesk Vault (version).

B On the desktop, double-click the Autodesk Vault icon.

1 In the Log in dialog box, enter your user name, password, the server
name, and the name of the computer.

2 Click OK.
Log into Vault
User Name: YourVaultUserName
Password: ——
Server: YourVault Server e
Database: ‘YourVaultDatabase ™ [:]
[] Automatically log in next session
| QK | [ Cancel ] [ Help ]

NOTE You may save your account information to automatically log into the vault
upon next use.

Managing Vault Folders

Using Vault, create the folder structure for the vault.
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Creating the Folder Structure

Autodesk Vault is used to create the folder structure for the vault. The root
directory in a vault is represented as §/.

NOTE Autodesk® Inventor™ only. Because Autodesk Vault uses the Autodesk Vault
project file as a reference for file organization, set the folder structure inside the
vault identical to the folder structure of the project on the local computer.

Create a folder

1 Right-click the Vault ($) folder, and then select New Folder.

T LT R TITT ———— — | #E Vault Explo]
All Folders Ol @) Filer
= [ Wault Explorer ($) |

E content cente|._.i Hews Folder. .. |
Lad i‘_‘}l Mews Library Folder, ..
I ee %y Add Files...

# [ Handle = &

+ [ scissor Get Entire Folder ...

My Search Folder:
My Check In Entire Folder...

Check Cut Entire Folder...
Unda Check Out Entire Folder. ..

Create Shortcut

Delete

TMews Label...

Go ko Working Folder

Expand Al
Collapse all

Properties. ..

2 In the New Folder dialog box, specify a name for the folder.

T New Folder

Folder: ||

[ 0K l ’ Cancel ] ’ Help

3 Click OK.

The folder is created below the root level of the vault. Additional subfolders
might be created automatically when you add files to the vault using the Vault
add-in for Autodesk Vault and for AutoCAD®-based products.
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Creating Library Folders

1 To add a library folder, right-click the root level directory ($), and then
click New Library Folder.

= 3 Wault Explorer ($

conkent cente [ Mew Ealder...
ad i‘_‘j Mew Library Folder..,
1 ees P AddFiles...
+ [ Handle
+ [ scissor Get Entire Folder. ..
[ My Search Folder Check In Entire Folder ...
Check Qut Entire Folder,..

Undo Check Qut Entire Folder ...

Create Shortcut

Delete

Mew Label...

Go to Working Folder

Expand Al
Collapse all

Properties...

2 In the New Library Folder dialog box, enter a name.

T New Library Folder

Faolder:

I OF l ’ Cancel ] ’ Help ]

You can create library folders directly from the root level of the vault or below
another library folder.

Managing Vault Files

Manage design and project files using Vault.

Any non CAD files can be added to a vault using Vault. When adding CAD
data from Autodesk Vault, or any of the AutoCAD-based products, be sure to
add the files from within the CAD application to maintain file relationships.

B For Autodesk Vault design files, use the Autodesk Vault add-in for Inventor.
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B For DWG host files containing xrefs in applications such as AutoCAD,
AutoCAD® Mechanical, AutoCAD® Electrical, or Autodesk® Mechanical
Desktop®, use the Autodesk Vault add-in for AutoCAD.

File relationships are maintained among files stored in the vault. When getting
a file, checking a file out, or checking a file in, the files related to a selected
file can be included. The following terms refer to related files:

Children Files on which the selected file depends.
Parent Files that are dependent on the selected file.

Fp Engine.iam

(] Drigin

- (B Engine Internals:1
(] Drigin

() Engine Con Rod: 1
(771 Engine: Piston: 1

(771 Engine YWrisk Fin:
() Engine Crank Shaft: 1

Autodesk Vault can be used to manage and track the many different types of
files and data associated with a design project, including Autodesk Vault and
AutoCAD data, to documents and spreadsheets.

File Status lcons

The following icons indicate the status of files in the Autodesk Vault window,
the Vault browser in Autodesk Vault, , and the Xrefs Manager in
AutoCAD-based products.

Icon Description

q Not in the vault or the file has missing parent/child relationships. Use the Add
1 Files command to add the item to the vault or resolve the missing links.

Checked in to the vault and the version you are working on is the same as in
' the vault. Also referred to as the Latest Version.
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Icon Description

Checked in to the vault, but the version you are working on is newer than the
latest version in the vault. This typically means that the local file was changed
without checking it out. To save the changes, check the file out, and make sure
the Don't Get Local Copy option is selected.

Checked in to the vault, but the version you are working on is older than the
latest version in the vault. This typically means that another user made changes
since your last update. Use Get Latest Version to update to the latest available
version.

® ©

Checked out to you and the version you are working on is the same as in the
vault. Also referred to as the Latest Version.

-EI

Checked out to you, but the version you are working on is newer than the latest
version in the vault. This typically means that you made changes to the model

since the last time you checked out the file, but have not checked it back in.
Checked out to you, but the version you are working on is older than the latest
version in the vault. This typically means that you started with a version from
the vault that was older than the latest, and checked it out to promote it to the

latest.

IHI Checked out to another user, and the version you are working on is the same
as in the vault. Also referred to as the Latest Version. This typically happens if
the other user did not check changes back into the vault. Check with the other

user before proceeding.

@ Checked out to another user, but the version you are working on is newer than
the latest version in the vault. This typically happens if the user checked in saved
changes to the vault, but kept the file checked out. Use Get Latest Version to
update to the latest available version.

Checked out to another user, but the version you are working on is older than
the latest version in the vault, and another user checked out this file. Use Get
Latest Version to update to the latest available version.
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Icon Description

Autodesk Vault only: User is not logged into the vault.

llﬂ das attachments. Expand the tree to see what files are attached.

das third-party OLE linked files. This is displayed in the Autodesk Vault browser
@ only. Expand the tree to see what files are linked.

2rrors to add the files to the vault. This icon can also mean that you need to set
a project folder mapping in the Map Folders dialog box.

ﬂ An an error occurred when adding your project to a vault. You must resolve the

File doesn't exist in the expected working folder. This is common in two cases:

I::i:l 1) you created a new file but have not saved it to disk yet, and 2) an attachment
isn't in the same folder as the file it is attached to. This is a requirement for files
that are attached to Autodesk Vault documents.

Library folder. The files within this folder are not intended to be edited when
used in context of another assembly.

Choose between the large and small icons

1 Select Tools » Options in Vault.

2 By default, the small icons are used to indicate status. Turn on the Use
large status icons check box to display large icons.

! File Edit Wiew | Tools | Actions  Help
P mew - (2] Advanced Find. .. Ctrl+Shift+F
(] arFies |92 Find Clr4F
= Labels. ..
All Folders Customize...
&= L3 Yault Explore Administration. ..
31
B 111 | Cpkions...
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Adding Files to aVault

1 Right-click a vault folder, and then click Add Files.

= 3 Wault Explorer ($) NS
content centerl o
eee
| gear [ %]
# [ Hang =1 | Mew Folder...
+ [ sciss

My S
S Fies.

Get Entire Folder...
Check In Entire Folder. ..

2 In the Add files dialog box, select the file to add to the vault.
3 Click OK.
After adding a file to the vault, you can delete the local copy. When you want

to view or modify a copy of the file, use Autodesk Vault to retrieve a version
of the file and check it out.

Moving Files within Vaults

1 Ask all users to check in their local data and delete the local copies.

2 Using Autodesk Vault, drag one or more files from the existing location
to a new location, to reflect the new file organization.

3 Drop the file in the new location and select Move from the context menu.
4 Check out the Autodesk Vault files and resolve any broken links.

5 After the vault files are moved and broken links are resolved, ask all users
to log into the vault and get the latest version of the top-most file to their
working folders.

Attaching Files in the Vault

An attachment among files links them in the vault. You can manually add
attachments among any two or more files within the vault. Using attachments,
you can check out all the files that are linked, and work on them as a unit.
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You can attach different file types. For example, you can attach a set of images
to a Microsoft® Office Word document, and you can attach assembly
instructions to the actual CAD assembly files.

NOTE Do not attach files that can be assembled (Autodesk Vault) or referenced
together (AutoCAD-based products).

Attach a file
1 Select a file in the vault for which you want to define an attachment.
2 In the Vault menu, click Attachment or right-click the file to which you
want to add an attachment, then click Attachment.
3 The Attachments dialog box displays the current attachments.
4 Click Attach.
T Attachments for "Bottle.ipt' - Version 2
Attached Files:
File Mame Wersion Created By Checked In Comment
p/upload. png 1 Adrinistrator 12)2/2005 4:00...
[ wiews attachments For previous versions
’ oK ] ’ Cancel ] ’ Help ]
A4
5 A file browser is displayed. Browse to and highlight the files you wish to
attach. To select multiple files, use a crossing window or hold down CTRL
or SHIFT.
6 Click Open.
The selected files are listed in the Attached File list in the Attachments
dialog box.
7 When you finish all attachments, click OK.

Remove an attachment

1

Select the file in the vault from which to remove an attachment.
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On the Vault menu, click Attachments.
In the Attachments dialog box, select the file to remove.

Click Detach.

w©n A W N

Click OK to detach the selected files and close the Attachments dialog
box. A new version of the file is created in the vault with the selected
files removed from it.

As a project grows, it may become necessary to move files and change the
folder structure within a vault. Use Autodesk Vault to reorganize files and
folders on the server.

NOTE Reorganizing files is only performed using Autodesk Vault. Never move files
that are located in the working folder.

Renaming Files Within Vaults

As a project grows, it might become necessary to rename files within a vault.
You must use Autodesk Vault to rename files so that file relationships are
maintained.

If you want to rename the folder, make sure all the files in the folder are
checked into the vault. A folder cannot be renamed if any of its files has an
external dependency.

For more information about renaming vaulted files, see the Help within
Autodesk Vault.

Labeling Files

In Vault, you can label development milestones such as customer proposals,
design reviews, or concept variations so they can be easily identified. Using
labels, you can establish baselines and track progress for work-in-progress files.
You can also rename labels, extract labeled files from the vault using Pack and
Go, and restore labeled files.

When you create a label, the most recent checked in version of every file in
the project is assigned that label. There is no limit to the number of labels
that can be assigned to a project. You cannot create more than one label with
the same name. For more information on labels, see Labeling Files in the
Autodesk Vault Help.
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Label a file
1 Click File » New Label.

File | Edit Miew Tools  Actions

i Mew ]
€4 Add Files...

Log In...

FIE

g | Logout

@ Expart...

Page Setup. ..
8| User Profile. ..

| Mew Label,.,

Set working Folder. ..

2 In the New Label dialog box, enter a name for the label that indicates
the milestone for that project. Label names can contain any alphanumeric
text, excluding \ / : *? "< > |.

3 Optionally, enter a comment to describe the label. Labels help identify
the contents of the label.

4 Click OK.

Copying Designs

Create new products based on existing Autodesk Vault or AutoCAD designs
by copying the entire assembly structure along with the related 2D drawings
for 3D models within Autodesk Vault. You can manipulate existing assemblies
to derive new designs and "one offs" complete with documentation.

In the Copy Design dialog box, you can selectively choose which parts of an
existing design to copy, reuse, exclude, or replace. A naming scheme can be
defined for the files being copied to the new design. A prefix and a suffix can
optionally be added to the files automatically. The new files can also be
automatically incremented if the original file names end in an integer. This
is useful for when CAD files are named using item or part numbers. Autodesk
Vault presentation files and drawing files can be automatically named to
match the names of their direct part or assembly child.

For more information, see Copying Designs in the Autodesk Vault Help.
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Copy a design
1 Select a file in either the main pane or the preview pane.
2 Click Copy Design in the toolbar.

3 In the Copy Design dialog, specify which parts to reuse, exclude, copy,
or replace.

4 Click OK.

Understanding Check Out

When you check out a file, the read-only attribute of the local copy changes
to read/write, and you can edit it. No one else can modify a file you check out
until you check it back into the vault, but they can retrieve read-only copies.
Only one member of a team can check out a file at one time.

Check out a file to edit

1 In Autodesk Vault, right-click a file, and then click Check Out.

i TR Bt bt 3 Airimminiske a1 315 (0, 5
(7 |Marker_Cap.ipt 1 View in Window...
Cervet. idw 1 Edit
| |Cover.ipt 1

|_§3 Check Qut...

2 In the Check Out dialog box, you can add a comment.

NOTE Autodesk Vault relies on consistent file locations to resolve links. Check
files out to the default working directory.

As you check files out and in, use comments to add information for
managing versions and to track the actions performed during the last
working session. Use the advanced options to check out the parents and
children of the selected file.
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@ Check Out "Lock Shackle.ipt

Checkout to:
C:\Program Files®Autodesk\Vault 4%SamplestInventorPADLOCK Padlock D

[] Dont get local copy

= [¥]3 $/Padiock/Parts
[T Lock Shackle ipt

Enter notes to include with this version:
Checking out to make changes per spec...

oK | [ Cancel | [ hHep |

A

3 Click OK.

A check mark next to a file indicates that the file is currently checked out
for editing. No other team members can check out a file that is currently
checked out. However, others can get read-only previous versions and
latest checked in versions of files that are currently checked out.

NOTE You can also right-click a folder, and click Check Out Entire Folder.

Understanding Check In

Check In returns the local copy of the file to the vault with the changes that
have been made. When a file is checked in, it becomes the latest version and
is accessible to others.

You must check in files from the working folder from which they were checked
out. If files are moved from the working directory, you cannot check them
back into the vault but you can undo the check out. The file properties
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CheckOutMachine and CheckOutLocalSpec specify the required location of

the file.

Check in a file

1 In Vault, right-click on a file, and click Check In.

M () Bottle,ipt 3 Administrakar
@ Marker_Cap.ipt 1 Yiew in Window...
ER Cover.idw 1 Edit
(| |Cover.ipt 1 |_§5 checkIn..,

2 In the Check In dialog box, you can:

Check in the file with your changes.

Check in your changes and keep the file checked out for further
editing.

Delete the local copy upon check in if you check in the file.

Add a comment containing information about changes made in the
file.

Use the Settings options to check in the parents and children of the
selected file.
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@ Check In "Lock Shackle.ipt

[ Keep checked out [] Delete local copy

= [¥]3 $/Padiock/Parts
e

e/ 25116

Enter notes to include with this version:
Updated shackle length per ECOJ..

[ ok ] [ canced | [ Hep |

3 Click OK.

The information for the file in Vault indicates that the file is checked in.
The file becomes the latest version and other team members can check
it out.

NOTE You can right-click a folder, click Check in Entire Folder.

Understanding Undo Checkout

Undo Checkout removes the checked out status on the file. The latest version
of the file that was checked in is restored to the vault.

Undo a Checkout

1 In Vault, right-click a file, and then select Undo Check Out.
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g m = Yiew in Window... e
(| [Marker_Cap.ipt 1 _
Cover.idw 1 o i
| |[Cover.ipt 1 A CheckIn... ]
Check Ouk... I
|_-f,| Undo Check Cut... |

A prompt indicates that undoing a checked out file results in a loss of
changes.

2 To make the local file the same as the file in the vault, select Replace
working copy.

@ Undo Check Out 'Lock Shackle.ipt
Replace local copy [ Delete local copy

= V|3 $/Padlock/Parts
[#I]) Lock Shackle ipt

TN

[ ok | [ cancd | [ Hep |

A

3 Click Settings to specify whether or not the children of the selected file
are included.
4 Click OK.

The file has been returned to the vault. Any changes made to the local
copy are lost.

NOTE You can right-click on a folder and then select Undo Check Out Entire
Folder.
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Displaying Version History

In addition to tracking versions, Autodesk Vault tracks properties associated
with the data. You can use the version information and properties to help
manage and search for data.

The files stored in the current vault are listed in the main pane of the Vault.
Version and file information for the selected file is displayed in the bottom
pane under four tabs; Versions, Uses, Where Used, and View. Each heading
at the top of the pane represents a property field for the file. As you add more
properties to a file, more fields are available for customizing the views within
the tabs.

1 Select a file in Autodesk Vault.

2 Click the Version tab in the preview pane.

00 File Mame Yersion Created By Checked In Comment
YO el
@[ aof[Marker_Handle.ipt 2 Administrator
@3 0| Market_Insert.ipt 2 Administratar

Yersions | Uses | Where Used | View

Number of versions: 4
Local Same As: Wersion 4
File Name Wersion Created By Checked In Carmment
p|Marker_Cap.ipt 1 Administrakor 1/14j2006 4:30 PM
Marker_Cap.ipt 2 Adrminiskrator 1/16/2006 2:558 PM
Marker_Cap.ipt 3 Administrator 1/16/2006 3:14 PM
Marker _Cap.ipt 4 Administrator 1/16/2006 3:15 PM

Getting Latest Versions

Get Latest Version retrieves a read-only copy of the most recent design data
that is checked in. You cannot modify it until you check it out using Autodesk
Vault or a Vault add-in product.
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Get the latest version of a file or folder

1 In the Vault window, right-click the file or folder, and then click Get
Latest Version.

pi o [J]  Bottleipt Z A TSI nnG. A
| Marker_Cap.ipt 1 Yiew in Window...
Covet.idw 1 Edit
£ |[Caover.ipt 1

| Check Out...
[lﬂ Attachments...
Versions | Uses | Where Used | View '3 Get Previous Version. ..
MNumber of versions: 2 _21 Get Latest Yersion... |

2 In the Get Latest Version dialog box, click OK.

The most recent version is copied to the local working folder. If the most
recent version in the vault is different from the copy currently in the
working folder, you are prompted about overwriting data.

Click Settings to get the parents and children of the selected file.

T Get Latest Version of ‘Bottle.ipt
Get Latest Version ba!
CiDocuments and SettingsiymengiMy Documentsivaultiees) E]
"t £
= F_iﬁ $lece

I Bottle.ipt

NOTE Autodesk Vault only: Library files and referenced files outside of the
workspace are retrieved to a directory parallel to the working folder. To ensure
that the correct version of the libraries are referenced, check out the project file
from the vault and modify the library search paths to point to the new location.

Getting Previous Versions

Get Previous Version retrieves a past version of a file or a project and places
a read-only copy in your working folder. Historical versions can never be
modified. You can only create a new version of a file.
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Get a previous version of a file or project

1 In the Vault window, right-click a file or project, and then click Get
Previous Version.

B @ Battle.ipt 2 Adroinistrabor 120202005 3:53
(| [Marker_Cap.ipt 1 Yiew in Window...
Cover.idw 1 Edit
7 Cover.ipt 1

Z CheckOut...

| Attachments. ..

Yersions | Uses | where Used | View

0% et Previous Yersion... |

a1

Number of versions: z 5 Get Latest Version,.,

2 In the Get Previous Version dialog box, select a version of the file or
project to retrieve.

A Get Previous Version of ‘Bottle.ipt*
Get Previous Version ko:
Cii\Documents and SettingsiymengiiMy Documentsivaultiees), E]
Version | Yersion 2 v

Wersion 2
= Wersion 1
“ta| 822

= ﬁ $leee
I Bottle.ipt

3 If the file has parents and children to get, click Settings, and then specify
which related files are retrieved as well.

4 Click OK.

A read-only copy of the file is placed in the local working folder. You can view
the file but you cannot modity it. To modify the file, you must check it out.

NOTE Autodesk Vault only: Library files and referenced files outside of the
workspace are retrieved to a directory parallel to the working folder. To ensure
that the correct version of the libraries is referenced, check out the project file
from the vault and modify the library search paths to point to the new location.

Viewing Previous Versions

1 Select a file in Autodesk Vault.
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2 Click View tab in the preview pane. The associated .dwf file of the selected
file will be displayed using Autodesk DWF Viewer.

3 Choose the file version which you want to view by the version slider in

the View tab.
| O| [j| @ ||-'__u|| File Mame | Wersion | Created By | Checked In Comment
Y O] [Bal[Marker_Cap.ipt 7 Administratar 1/20/2006 10:57..
| @ ﬁ 20| Marker _Handle ipt 2 Administrator
|| 20| Market_Insert.ipk 2 Administrator

wersions | Uses || where Used | Wiew l

File Mame: Marker_Cap.ipt
[ Wigw in Window. ..

Displaying Other Files Used

1 Select a file in Autodesk Vault.

2 Click the Uses tab in the preview pane.

The selected model is shown at the top. Other files used by the currently
selected file, and the children and attached files are listed in a hierarchy
as shown in the following illustration.
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W) E File Mame Yersion Created By Checked In

Camment
% Handle.ipj 1 Adrniniskrator 1/14/2006 4:30 PM
b | Hamdle.iam 3 Administratar
Versions | UsEs | Where Used || Yiew
Direct Children:
Total Children:
File Name Wersion Created By Checked In Comment
Lakest |w
H=HE
> @ Marker ... 4 Adminiskrakor 1716/2006 3:15 PM
() Marker .. 2 Administrator
() Market ... 2 Adrinistratar
Displaying Where Files Are Used
1 Select a file in Autodesk Vault.
2 Click the Where Used tab in the preview pane.
Alist of parents in which the selected file is used is displayed. The component
is listed at the top. Each assembly using the part is listed as follows.
)W) E File Mame Yersion Created By Checked In Comment
M) =o| Marker_Cap.ipt 4 Adrministratar 1/16/2006 3:15 PM
| =] Marker_Handle,ipt 2 Adrminiskratar
| =] Market_Insert,ipt 2 Adrminiskratar

Yersions | Uses | Where Used | yigw

Direct Parents: 1
Total Parents: 1 [~ Include Parent Yersions
File Mame Wersion Created By Checked In Comment
Latest |+
¥ =0
> g Handle. ... 3 Administrator
|

Displaying Where Files Are Used | 29



Publishing DWF Files

DWEF files can be automatically published for CAD files checked in to the vault
using the vault add-ins for supported CAD applications. The .dwf attachments
are only created for files that have changed or for files that do not have .dwf
files published already. Automatic .dwf publishing can be turned off to save
room and keep the size of the vault down. You can also specify a default folder
location for the published .dwf files. For more information on automatic .dwf
publishing, see Help in Autodesk Vault or each of the supported CAD
application add-ins.

Performing Searches

Use the Advanced Find dialog box for basic searches and to create customized
search criteria for locating specific information in your data. If the Content
Indexing Service is enabled on the Autodesk data management server, you
can search the content of files as well. For more information on searching,
see Autodesk Vault Help. For more information on enabling content indexing,
see ADMS Console Help.

Performing Basic Searches

1 On the Tools menu, select Advanced Find, and then click the Basic tab.

2 Enter your search criteria. Click Find Now.

The results of the search are displayed at the bottom of the Advanced
Search dialog box.

Performing Advanced Searches
1 On the Tools menu, select Advanced Find, and then click the Advanced

tab.

2 In the Property list, select a document property.

The Property list contains all the properties associated with the files stored
in the current vault.

3 In the Condition list, specify a condition by which to search.
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4 Enter a value to be used in the search criteria.
5 To add the search criteria to the list of stored searches, click Add.

6 Click Find Now.

The results of the search are displayed at the bottom of the Advanced Search
dialog box.

Packagi

ng Files with Pack and Go

Pack and Go packages a file and all of its referenced files in a single location.

A

11 files that are referenced by a selected file are included in the package unless

otherwise specified in the Pack and Go dialog box.

Use Pack and Go to:

Archive a file structure.

Copy a complete set of files, while retaining links to referenced files.
Isolate a group of files for design experimentation.

Retrieve a previous version of a design and copy it into an isolated folder.

Send the package to a mail recipient.

Package a set of files

1 Select a file from the file list in Autodesk Vault. Click File » Pack and
Go.

Fil= | Edit ‘“iew Tools Actions  Help

T 3 | *
€| AddFiles. . - |j
Log In...
| Log Qut e
Export...
Page Setup. ..
8 User Profile. ..

Mews Label. .
Set Working Folder, .,
Folder 4
Print Preyview. ..

|ﬂ Packand Go...
Send...
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The Pack and Go dialog box shows a list of the files to be packaged.

M Pack and Go - Pad Lock.iam
Package Type: Send Ta:
Unzipped v Destination Folder K4
‘ersion ko Get: Output Structure:
Version 5 (Latest) d Keep Folder Hierarchy B4

=-[#]C3 Parts -~
I case Back.ipt |
I case Inner.ipt
I case cuter.ipt
[#I] catch Body.ipt
[ catch Post.ipt
I catch Spring - Coil.ipt
[ catch Spring - Flat.ipt
I catchipt
[ combo Backing Plate.ipt
[Vl ©Combao Plate iPart.ipt
=-[¥]4 Combo Plake iPart
[#]48 Combo Plate Lower.ipt
[#]48 Combo Plate Upper.ipt
[V1F7) Combo Spacer Motch.ipt s

24 files Sethings...

{ OK ] [ Cancel I [ Help ]

2|

2 You can:
B Package the files to a .zip file or create a DWF package, a single .dwf
file with each file represented as a page in the .dwf file.
B Select which version of the files to package.

B Specify the destination for the package, either a folder on the local
computer or a mail recipient.

B Determine the structure of the files being packed. You can flatten all
files and place them in a single folder, or preserve the structure as it
appears in the vault.

NOTE If you choose to flatten all files and place them in a single folder, any
file sharing the same name as another file is automatically renamed to avoid
file name collisions. This may require that you manually resolve the renamed
files in their native CAD systems.
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3 Click Settings to select which related files will be included in the package
and whether or not .dwf files are included.

T Settings

Relationships

(®) Include children onky

O Include all related files

Duwif Filker

O Include
() Exclude

() Dwf Crly

[ [o]'4 l [ Cancel ] [ Help ]

4 Click OK. If the destination for the package is a mail recipient, an empty
e-mail window is displayed with e package included as an attachment.

For more information on packaging files, see Autodesk Vault Help.

Customizing Vault

In Vault, you can customize your work environment. By suppressing dialog
boxes for certain commands and controlling the default responses to various
prompts, as well as when prompts appear you can greatly streamline your
workflow. For more information on customizing your workflow and
suppressing recurring prompts, see Autodesk Vault Help.

Customize your work environment

1 Click Tools » Options. In the Options dialog you can do the following:
W Select Use large status icons to display large icons.

B Select Show working folder location in title bar to display the location
of the working folder in the user interface.

B Select Show hidden files to display the hidden files in the file list such
as .dwf files.

B When you double-click a file in the vault, the default action is to
display the read-only file in a new window. If Edit is selected as the
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default, the file is checked out of the vault and opened in the
associated application for editing. To change the default action, select
an action from the drop-down list.

B Configure prompts. To do this Click Prompts... A list of prompts
appears. To modify the default response to a prompt click the
dropdown menu in the Response cell. Go to the Frequency cell to
adjust when and how often a prompt appears. Click OK.

T Manage Prompts

Click a cell to edit directly.

Command Frompt Test Fesponze Frequency

v.
Delete File Are you sure pou want to permanently del.. [Nao Always Prompt
Delete Folder Are you sure you want to permanently del. (Mo Always Prompt
Delete Files Are you sure you want to permanently del. (Mo Always Prompt
Delete File link  |Are you sure vou want to remove the link t. Mo Always Prompt
Get Previous V.. |File Y0} iz checked out to you. Are you 5. [Yes Always Prompt
Get Latest Wer. |File 10} is checked out to you. Are you 5. [Yes Always Prompt
Get Previous V.. [Working copy of {0} is NEWER than a va.. [Yes Toal Always Prompt
Get Latest Wer. |Working copy of {0} is NEWER than a va.. [Yes Toal Always Prompt
Check Out wiorking copy of {0} is NEWER than a va.. Mo Always Prompt
Check Out wiorking copy of 0} i OLDER than the .. [Yes ToAll Mever Prompt
Prompk Text

A non-configuration member file, 40}, is about to be moved into a folder containing configuration members,
Would vou like bo continue?

OF l [ Cancel ] [ Help ]

A

2 In the Dialog Suppression Panel, there are four dialog suppression options.
To suppress a dialog, select the checkbox next to it. Click the settings
button and adjust the default settings. Click OK.
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Opkions

|:| Use |arge skatus icons

[ 5how warking Folder lacation in title bar

[ 5how hidden files

Default double-click For files:

Configure default prompts

Dialog Suppression

[ check In dialog
Check Out dislog
Undo Check Out dialog

Get Latest Yersion dialog

Wigw in Window, ..

Prompts. ..

Settings. ..

Settings. ..

Settings. ..

III IE

[ [o]4 l [ Cancel

J |

Apply

J |

Help

]
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Working with Autodesk
Inventor

Learn how the Autodesk® Vault add-in integrates with Autodesk® Inventor™. Before you
proceed, make sure you are familiar with setting up Autodesk Inventor projects and the
structure of your design project.

Key Terms

Term Definition
Vault add-in for The Autodesk Vault client interface that is integrated with the Autodesk Inventor
Autodesk Inventor software application. This interface is used to manage the complex relationships

among Autodesk Inventor files and communicate this information to the vault.

project file The locations and settings that identify all the information necessary for a set
of Autodesk Inventor design files to resolve their relationships. The file extension
is .ipj.

library A collection of Autodesk Inventor design files that are commonly used in designs

and infrequently modified.

Check In Placing Autodesk Inventor files in the vault using the Inventor add-in. Always
use the Inventor add-in to add Autodesk Inventor files to the vault to retain file
and data relationships.

vault-enabled project ~ An Autodesk Inventor project file configured for use with Autodesk Vault. The
file multi-user setting is set to Vault and the paths are modified as necessary.
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Term

Definition

vault browser

A specialized browser added to the Inventor browser panel for working with
files in a vault. The vault browser is available once Autodesk Vault is installed
and the current project is vault enabled.

workspace

Within a vault project, the logical location for storing Autodesk Inventor files
for a design. Set up the file structure of the workspace folder to be the same as
the file structure of the local working folder.

Vault Add-in for Autodesk Inventor

The vault add-in works within Autodesk Inventor, and adds tools for managing
files using the Autodesk Inventor interface. Through the add-in, you can add
files to the vault, check in and check out files, and map folder locations. The
add-in works only with Autodesk Inventor files. We recommend you use the
add-in to place Autodesk Inventor design files in a vault so that relationships
among the files are preserved.

When the Autodesk Vault client is installed, the vault browser is added to the
Autodesk Inventor browser bar and the vault submenu is added to the Autodesk
Inventor file menu.

Organizing Files

Typical designs might include parts, libraries, iPart Factories, purchased parts,
and common manufactured parts. To organize your files for effective data
management, it is helpful to understand how Autodesk Inventor finds these
files using the workspace and library search paths in the Autodesk Inventor
project file, and how the Autodesk Inventor Content Library and iPart Factories
publish parts.

The workspace path in an Autodesk Inventor project file indicates the location
of the design data. In a vault-enabled project file, the workspace path specifies
the location of the design data in the vault relative to the project file.
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Specifying Workspaces in Vault Projects

In the vault project file, define the workspace path as a period (.), meaning
the same folder as the project file, or to a subfolder below the project file, such
as .\ Workspace.

NOTE The best practice is to set the workspace path to the same folder as the
project file.

For large design projects, the workspace folder can contain additional sub
folders. However, you cannot map a project search path to a workspace sub
folder.

For more information about setting up frequently used folders, see Autodesk
Inventor Help.

Specifying Libraries in Vault Projects

Libraries, including Content Center libraries, contain files that are used in
multiple designs. Library files do not change often and are frequently reused.
For example, common components that are purchased, such as fasteners or
electric motors, can be stored in a library.

Library files are typically stored in a library folder separate from the project
files on a shared server so that all members of a design team have access to
them. Library files cannot be modified in a vault-enabled project. Libraries
cannot be located within the cone of influence.

Creating Folder Structures in Vaults

The master files for a vaulted project are all stored in the vault. To modify the
files, they must be checked out to the local working folder. For ease of data
management, the vault folder structure is set up to match the working folder
structure for the project. For example, the vault folder structure for a project
called Clamp is set up parallel to the structure of the local working directory
and workspace folder.

Library folders cannot be located in the same folder structure as the model
files in the vault. You add libraries to a vault at the root level of the vault
directory. A project file must include a library search path for each of the
libraries used by the model.
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Working with Legacy Projects

Design projects that were created before Autodesk Vault was installed can
either be converted to vault projects or you can use Autodesk Autoloader to
create the vault project file. It is recommended you use Autodesk Autoloader
to create the vault project. Autodesk Autoloader uploads an entire Autodesk
Inventor project to a vault located on an Autodesk data management server.

To access Autodesk Autoloader: Program Files » Autodesk » Data
Management Server » Tools » Autodesk Autoloader. Learn more about
Autodesk Autoloader by clicking on Help.

NOTE If you choose to convert a legacy project to work with the vault using the
Project Editor, back up the project file and data.

Converting Projects to Work With Vaults

Existing Autodesk Inventor projects can be converted for use with Autodesk
Vault. To convert an existing project, you use the Project Editor to modify the
project file to work with the vault and add the design data to the vault.

For more information about modifying a project file to be vault compatible,
see “Converting Existing Project Files” in the Autodesk Vault Help.

Tips for converting projects to work with vaults
B [n a shared or multi-user project, set the Multi-user setting to Vault.

B Consolidate Autodesk Inventor design files and the associated .ipj file
manually.

B Before you remove a reference in the .ipj file, relocate the necessary design
files from that location to the one referenced in the vault enabled .ipj file.

B Setup libraries in the vault for common components that are shared across
multiple Vault Projects.
Include libraries for iParts and Autodesk Inventor Content Libraries that
are referenced by the project.

In the Autodesk Inventor Projects dialog box, verify that the Autodesk
Inventor Project File references the vault libraries correctly.

B For multi-user projects, make sure all users have their files checked in. All
current data must be in the workgroup.

40 | Chapter 4 Working with Autodesk Inventor



NOTE When converting an existing project to a vault-enabled project, turn on
Using Unique File Names in the Autodesk Inventor project file. For more
information, see Autodesk Inventor Help.

Moving Existing Data into Vaults

Existing Autodesk Inventor design data can be added to the vault. The data
can be associated with a legacy Autodesk Inventor project file that has been
converted to a vault project file or used with a brand new vault project file.
In the Autodesk Vault add-in for Inventor, use the command Add Project to
add existing data to the vault.

For more information about adding a project to the vault, see “Adding a
Project” and “How to Add Files (Inventor)” in the Autodesk Vault Help.

NOTE It is recommended you use the utility called Autodesk Autoloader for
uploading Inventor data into a vault instead of manually modifying the project
file with the Project Editor. Autodesk Autoloader is a stand-alone utility independent
of Autodesk Vault. Autoloader is available on the installation media. Contact the
vault administrator for more information about installation and usage.

Logging into Vaults in Autodesk Inventor

If a vault is not open, the vault browser displays yellow icons with exclamation
points in front of each file. When you log into the vault, the icons change to
indicate the current status of the files, and the vault features are available on
the context menu.

Log into a vault
1 Start Autodesk Inventor.

2 Click File » Autodesk Data Management Server » Log in.

3 User name The name for the vault account.
Password The password associated with the vault account.
Server The name of the computer where the vault server

is installed.

Database The name of a database located on the specified
server. The default is Vault. Click the browse button
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to select from a list of available databases on the
server.

4 A default user ID, vault server, and database are set up for you to get
started using the vault right away. If a user account has already been
created for you, enter your account information. If a user account is not
yet created for you or the default values are not present, contact the vault
administrator.

5 In the Log in dialog box, enter your user name, password, the name of
the vault server, and the name of the vault database.

6 Click OK.

Setting Up Vault-Enabled Projects

Autodesk Vault can manage only vault-enabled project files. When you start
a new Autodesk Inventor model, create the vault-enabled project file before
you create any model files. Configure the project file to take the maximum
advantage of Autodesk Vault.

Set up library folders in the vault to manage reusable common components,
iParts, and content libraries. You must map the library search paths in the
project file to the library folders in the vault.

For more information about mapping, see Mapping Folders on page 44.

Autodesk Inventor project files include several settings that tell Autodesk
Inventor where to look for model files. When Autodesk Inventor opens the
components of an assembly, it looks in the folders specified in the project file.
For example, if a component is a non library component, Autodesk Inventor
looks in the workspace folder specified in the project file. If a component is
a library part, Inventor looks in the library paths specified in the project file.

For more information about project files, see the sections about projects in
the Autodesk Inventor Getting Started manual.

NOTE Itis recommended you use Autodesk Autoloader to create the vault project.
Autodesk Autoloader uploads an entire Autodesk Inventor project to a vault located
on an Autodesk data management server.

Set up a new project file for a vault

1 Start Autodesk Inventor.
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2 In the Open dialog box, click Projects » New.

3 In the Autodesk Inventor project wizard select New Vault Project.

Inventor project wizard

What type of project are you creating?

% Mew Vault Project

" Mew Single User Project

@ Mext Cancel

4 Click Next.
5 Name the vault project and specify the project location.
6 If you are referencing existing part libraries in the new project, click Next

and select the libraries for the project.

If you are not referencing libraries, or you will be using new libraries, click
Finish instead.

Specify a new library path
1 Click File » Projects.
2 Double-click the new vault project to make it the active project.

3 Enter the library search paths where the library components are located
on the network.

4 Click Save. Click Cancel to close the dialog box.

The new project file is now vault-enabled. As you create files in the project,
you can add them to the vault using the Vault add-in for Autodesk Inventor.
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For more information about adding files to the vault from Inventor, see
Working with Files in Vaults on page 46.

Mapping Folders

After the vault enabled project file is created, map the project root and any
referenced libraries to corresponding folders in the vault.

Map the project root

1 If you are not currently logged into the vault, click on the File menu in
Autodesk Inventor » Autodesk Data Management Server » Log in.

2 Click File » Vault » Map Folders.

3 In the Project Folder Mapping dialog box, select Project Root, and then
click Edit or double-click Project Root.

I Project Folder Mapping
Mapping of local folders to Vault folders

Local Vault
(F)Project Root
@ Content Center Files

Edit....
@ | Cancel |

The Browse Vault for Folder dialog box displays a list of the folders in
the vault.

4 If the necessary folder exists in the vault, select the vault folder from the
list and then click OK.
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